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Introduction 
RDT is designed to be used with Icom transceivers. There are currently two different versions of RDT: 

RDT Live and RDT Pro. RDT Live provides real-time GPS location tracking using Icom LTE, SAT and 

F3400/F7000 series products. RDT Pro is for use with the Icom F3400/F5400/F4400/F6400/F7000 series 

products, Icom’s R30 and R8600 receivers. RDT Pro also supports the RDT Live features. 

RDT Pro converts voice logs from an Icom radio into an easy to view table format to playback voice and 

view its abundant metadata. At the same time, it creates a .kml file that can present voice data fully 

mapped on Google Earth. 

RDT Pro also can convert GPS and Power log data from the Icom radio for full viewing on Google Earth if 

the radio supports those features. 

Finally, RDT Pro takes voice files recorded on the Icom radio and formats and places them for use as 

custom channel announcements if the radio supports that feature. 

What’s New in 2.3: 
• P25 & IDAS Radios tabs are added to the Main Settings tab (File:> Settings) 

 

• RDT LIVE now supports P25, IDAS/NXDN and F3400_F5400 Railroad series radios. 

Note: Choose the IDAS tab for F3400 IDAS or F3400 RR series radios. 
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• Average RSSI level setting added: An average RSSI level column has been added alongside the 

original RSSI level column. Note: Firmware 3.6 or newer is required for F3400_F5400 Railroad 

radios. 

 
• Firmware 2.3 includes all features and settings from previous firmware/software versions. 

What’s New in 2.2: 

Introducing RDT Live 

• Replaces RDT LTE and includes the following 

o Support for Icom LTE series radios with real time and historical GPS Location viewing 

via the VE-PG4 or IP-501M. 

o Support for Icom SAT series radios with real time and historical GPS Location 

viewing via a connection to a base SAT series radio. 

RDT Pro 

• Added the enhancements listed above for the RDT Live  

Source 
You can get the latest version of RDT Pro and RDT Live at www.icomrdt.com. The latest version of this 

manual can also be downloaded from that website. 

Supported Operating Systems 
• Windows 11/10 

Disclaimers 
This product relies on data from the Icom radio and is no more accurate than the data derived from that 

device or the Google Earth tool used to present much of the data. This product is meant as an aid for 

troubleshooting problems with radio communications as well as incident analysis. It is not meant to be a 

navigational aid of any kind and events depicted should be verified independently depending on the 

severity of the issue. 

Prerequisites 
RDT Pro version 2.3 includes RDT Live functionality. 
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The previous version RDT software (not including the RDT Live functionality) use logs derived from SD 

card recordings on the Icom radio. In that regard, an SD card inserted into the Icom radio is required for 

this product to function. 

For voice log conversions, RDT Pro requires that voice logging be activated on the Icom radio of choice. 

It is strongly suggested that the GPS be activated also to take maximum advantage of what RDT Pro can 

do. Please see the settings on your Icom radio as shown below. 

RDT Live relies on proper programming of the VE-PG4 or IP-501M to provide the GPS Location 

information of the corresponding IDAS/NXDN , P25 & LTE radios. 

For SAT-100 radios, make sure location sharing is enabled on each radio that you wish to see on the 

map. 

F3400 and F5400 Series Radios 

 

Activate Call Record 
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Screen shot from non-RR firmware 2.0. Activate GPS by turning “GPS” to “ON”. Note that in this screen you can also 

activate GPS Auto Log by setting the field to “ON”. Interval Timer set to 30 seconds – can go to every 5 seconds as 

needed  

  

Screen shot from RR Firmware 2.6G. Activate GPS by turning “GPS” to “ON”. Note that in this screen you can also 

activate GPS Auto Log and Power Status Log by setting the respective fields “ON”. Interval Timer set to 30 seconds 

– can go to every 5 seconds as needed  
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For GPS log conversions, RDT requires that GPS logging be activated, as above. RR Firmware 2.6G and 

beyond also has power log capability and you can activate by turning Power Status Log to “ON”. 

 

Screen shot from F7000 series version 3.2 or greater. Activate GPS by turning “GPS” to “ON”. Note that in this 

screen you can also activate GPS Auto Log by setting the field to “ON”. Interval Timer set to 10 seconds – selection 

can be changed. 

 

Activate Call Record 

R30 Receiver (can only be used with RDT Pro) 

Follow the directions in Section 4 of the basic manual for that product. 
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Viewing the KML files 

Although any .kml viewer may be used for viewing, this manual uses Google Earth Pro. If using Google 

Earth Pro to view the .kml files created by RDT, Google Earth Pro must be installed on your computer. It 

is assumed that the user also knows how to generally operate Google Earth Pro. 

Once installed, you must go to Tools > Options in the menu and select the General tab.  Highlight Allow 

access to local files and personal data as shown in the following screen. If you do not select this setting, 

then you will not be able to play back audio files from the Google Earth map.  

Note: If utilizing Windows 7, you may find inconsistencies when playing back audio from Google Earth 

Pro. 

Also select Tools > Options > General > Show web results in external browser for best results when 

playing back voice files from map. 
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Installation 
Once the program has been purchased and downloaded following the instructions from Icom’s web site, 

it can be installed on a local PC. 

Click the .zip file download then click RDT setup.exe.  Follow the on-screen instructions to install. 

Registration and Installation 
The Activation License is generated for a specific PC, so the procedure below must be done on the PC 

that the software will permanently reside on. 

Trial Registration for RDT Pro or RDT Live 

When you first start the program, you will see the following screen.  

 

Note:  you will not see this screen if you have already licensed the product and are just upgrading. 

 

If you select Continue with Trial you will be taken to the program and you can immediately start using it. 

Once downloaded, it will operate in trial mode for up to 13 days. 

When you’re ready for a permanent license, you can select Help > License Information from the menu 

and register using the procedure described later in this section. 

If you start the program and you see the following screen, then your temporary license has expired. You 

must get the program’s license activated to continue to use: 

Permanent Installation 

The following screen will appear after the software is first loaded on the PC. 
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Click Activate License. This will open the following screen. 

 

 

1. Click (1) Copy Validating Code to Clipboard. This will generate a simple key, specific to your PC, 

that RDT will use to generate a specific code for your activation. 

• Send Validating Code to RDT. Open your email program, address it to 

rdtsales@icomamerica.com , and paste the simple key into the email. Note: It may take 

several days before you receive the License Activation Key response from RDT. 

mailto:rdtsales@icomamerica.com
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2. Paste the License Activation Code into the software. Once the License Activation Key has been 

received from RDT (this is up to 200 characters in length), carefully select and copy that key into 

your PC’s clipboard. Return to the License Information screen and select (2) Paste from 

Clipboard. 

3. Click (3) Activate License. The product is now fully licensed. 

Additional Notes 

• The program will run without activation for a total of 14 days once downloaded. After that, it 

will switch to an unlicensed state and most functions will not be available.  

• RDT is allowed to run on a total of two machines per purchased copy (one on a desktop PC and 

another on a laptop for example). No further installations are authorized. If at some point, you 

wish to move your copy of RDT to a different machine, please contact 

rdtsales@icomamerica.com. 

mailto:rdtsales@icomamerica.com
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Menu Functions 

File Menu 

The File menu allows you to select settings and exit the program. 

File > Exit will end the program. 

File > Settings will give you the Configure screen, which contains the Main Settings Tab and the LTE 

Settings Tab 

Note: The Main Settings Tab is available in the RDT Pro version. The LTE and SAT Settings Tab is available 

in the RDT Live and RDT Pro version. 

Main Settings Tab 

 

 

Note 

Some of these settings may have no function depending on the model of radio you are using with RDT. 

When completed, click OK to save the information or Cancel to exit without saving. 
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General Settings 

Auto Detect Radio: Program will try to automatically determine if the Icom radio is connected. If so, it 

will automatically select the correct folder on the SD card for recorded audio files. You can then navigate 

to the sub-folder where you pick the file(s) you are wishing to convert. 

GPS Log Settings 

Use Radio ID in File Name: when selected, a small screen will pop up that allows you to enter the unit ID 

of your choice. This ID would typically be the Unit ID of the radio if NXDN is being used, but can also be 

the radio’s ESN or any other designator you choose (up to 15 characters). The Radio ID programming 

screen will be displayed when you are converting GPS logs, right after you select the files.  

This ID will then appear prepended to the GPS log file name. It will also show up in each record inside 

the newly created .kml file. 

Not selecting this setting will prevent the Radio ID programming field from being displayed and any .kml 

file created will have a generic name. 

Use Local Time in Conversion: All times in the .kml file created from your GPS log will be converted to 

your local time zone (as selected on your PC). This may make file analysis easier than trying to view files 

in UTC time. 

Use Preset .kml Location for Each Conversion: This is the folder location that the .kml file created from 

your GPS log conversion will be stored. If this is unchecked, the application will prompt you to set a 

location for .kml file storage each time a GPS log conversion is run. 

.kml File Location: Enter location where you would like the .kml file created by the GPS log conversion 

to be stored. 

Voice Log Settings 

Note: local time conversion already occurs in the radio for this log so there is no option to provide UTC 

time. 

Volume Display: Voice logs show the volume level the radio was set to when it received a call. It can be 

set to show either an absolute number from 0 to 255 or a percentage of full volume. 

Unit of Measure: Select if you wish units of measure in the converted log to be displayed in Feet/Miles 

or Meters/Kilometers 

Use Preset .kml Location for Each Conversion: This is the folder location where the .kml file created 

from your voice log conversion will be stored. If this is unchecked, the application will prompt you to set 

a location for .kml file storage each time a voice log conversion is run.  
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.kml File Location: Enter the location where you would like the .kml file created by the voice log 

conversion to be stored. 

Radio Port Settings 

This section allows you to control an Icom radio using a secondary control cable using the USB Mode 

Select button on the main screen. 

Baud Rate: Select the baud rate to match your radio. Typically use the default of 4800. 

Com Port: Select the com port you want to use to for USB Mode Select. This is typically the cable hooked 

to the radio’s USB port. 

USB Mode Select Settings 

Select “Mode 1” for method that allows for USB mode select state change with a single cable. Note: Only 

useful for Railroad Firmware 2.6G or later. 

Select “Mode 2” for two cable method of changing USB mode select. 

More on this in the USB Mode Select section of this manual on page 32. 
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LTE Settings Tab 

 

When completed click OK to save the information or Cancel to exit without saving. 

Connection 

This section allows for entry of connection information for the VE-PG4 or IP-501M.  

IP Address:  Enter the IP Address of the VE-PG4 or IP-501M. 

UDP Port:  Enter the UDP port of the VE-PG4 or IP-501M. Default is 24100. 

User Name:  User name associated with the log on set up for VE-PG4 or IP-501M. 

Password:  Password associated with the log on set up for VE-PG4 or IP-501M.                               
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Status List 

Add status 1 – 10 with appropriate name to match programming on the IP-501 programming. 

ID:  Enter any ID 1-10. 

Name:  Enter the appropriate name for the given status ID. 

Alias List 

Add/Remove unit IDs and alias information to properly display the Unit Alias for the LTE units. If not 

entered the Unit ID will be displayed in the LTE viewer and corresponding map view. 

ID:  Enter a Unit ID between 1 – 65535. 

Name:  Enter the corresponding name for the IP-501 Unit ID. 

SAT Settings Tab 
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Connection 

This section allows you to select between a TCP or Serial connection to the SAT-100. 

TCP 

Only available for the SAT-100M. 

IP Address: Enter the IP Address of the SAT-100M. 

TCP Port: Enter the TCP Port used for the Control Port of the SAT-100M. Default if 53000. 

Serial 

Serial Port: Choose the serial port connection to the SAT-100. 

Baud Rate: Choose the baud rate for communication to the SAT-100. Default is 19200. 

Available for the SAT-100M via the DB-25 connector or the SAT-100H via Bluetooth. 

Alias List 

Add/Remove unit IMEIs and alias information to properly display the Unit Alias for the SAT units. 

ID:  Enter the 15-digit IMEI of the SAT-100 unit. 

Name:  Enter the corresponding name for the SAT-100 IMEI.  

P25 Settings Tab 
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Serial Port: Choose the serial port connection to the P25 radio. 

Baud Rate: Choose the baud rate for communication to the P25 radio.. 

Talkgroup ID and Unit ID Alias List 

Add/Remove Talkgroup ID and alias information to properly display the Unit Alias for each radio. 

Add/Remove Unit ID and alias information to properly display the Unit Alias for each radio. 

IDAS Settings Tab 

 

Serial Port: Choose the serial port connection to the P25 radio. 

Baud Rate: Choose the baud rate for communication to the P25 radio.. 

Talkgroup ID and Unit ID Alias List 

Add/Remove Talkgroup ID and alias information to properly display the Unit Alias for each radio. 

Add/Remove Unit ID and alias information to properly display the Unit Alias for each radio. 

Model Menu 

The model menu allows you to select the radio you wish to work with. 

RDT Live works with the IC-LTE and IC-SAT series. RDT Pro adds the IC-F3400/F5400 RR Series, IC-

F3400/F5400 Series, IC-F7000/F7500 Series ,IC-R30/ IC-R8600, IC-LTE and IC-SAT series. 

Keep in mind that as you select different models, any functionality restrictions will be indicated by the 

corresponding action buttons being grayed out. 
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View Menu 

The View Menu will allow you to view already created voice logs and event logs. 

View->Voice Log:  Clicking on this field opens the voice log view. This table will have no entries if no 

conversions have been run since the program was started otherwise, this table will be populated with 

entries if a conversion has been run. 

See the Voice Log Viewer in the following paragraph. 
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Voice Log Viewer 

 View > Power Log (F3400/F5400 Series Radios only with RR 2.6G or Later Firmware Installed) 

Clicking this field opens up the power log view. This table is derived from GPS log files will have no 

entries if no conversions have been run since the program was started otherwise, this table will be 

populated with entries if a conversion has been run. 

View > Event Log 

Opens up the event log so that you can see recent program events. 

Help Menu 

Help > Contents F1:  Opens this help guide. 

Help > License Information:  See Registration and Installation as described earlier in this manual. 

Help > Contact Us 

Shows the contact information. 

Help > About  

This shows the version of the program as well as other information. 



 

21 

RDT Instructions | 

©2019 Icom America Inc. The Icom logo is a registered trademark of Icom Inc.  

Action Features 

 

 

  

Convert Voice Logs 

Pressing Convert Voice Logs will allow you to select the voice logs of your choice for table/map 

conversion.  

Depending on settings, different things will occur when this button is activated: 

Auto Detect Radio in General Settings section.  

 

If checked: 

• Icom radio is connected via USB and radio is in Card Reader Mode. 

You will be taken to the top level directory for voice logs on the radio’s SD card. Pick the folder 

with the date you are interested in and then one or more voice files you wish to convert 

• Icom radio is not connected via USB or not in Card Reader Mode. You will get the following 

message. 
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Clicking OK will bring up a file selection screen to allow you to pick voice files from alternate 

locations. 

If unchecked: 

• Regardless whether a radio is connected or not you will get a file selection screen to allow you 

to pick voice files from alternate locations. 

Use Preset .kml Location for each Conversion in the Voice Log Settings section.  

 

If checked: 

• The voice files will be automatically copied and placed in the location as listed in the .kml File 

Location setting along with the newly created .kml file. 

You’ll be presented with the voice log table. 

If unchecked: 

• You will be presented with a file selection screen so that you can determine what directory you 

want your .kml file and voice logs to be stored in. 

Once OK is clicked the voice files will be automatically copied and placed in the location you just 

selected along with the newly created .kml file. 

You’ll be presented with the voice log table. 

Once the file chooser is displayed, pick the file you’d like to convert. Note that more than one log file 

can be selected using standard ctrl or shift Windows conventions when picking a file. The files will all be 

combined into one .kml file. 

When the files are selected, a table is generated, and Google Earth opens to display the information 

from the files. 
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Voice Log Viewer 

When populated the voice log will contain a significant amount of metadata from the voice file – most of 

this metadata is self-explanatory. You can also open and remove additional logs if you wish. 

Open Log:  Open an existing voice log table. Once pressed navigate to the voice log folder of your choice 

and open the table that ends in “_vcli.xml”. 

GeoLocate Selected Row(s): Select a row of choice by clicking anywhere in the row. Select GeoLocate to 

open this position in Google Earth. You can select multiple rows by standard ctrl or shift Windows 

conventions on desired rows. 

GeoLocate All Rows: Display Google Earth with all rows selected. 

“X” on tab: Close selected tab (note: “Current” tab cannot not be closed) 

Media Player: 

Play All – Plays all files from the selected file to the end of the list. Button outline will be Red in color 

while Play All is active. Click Stop to exit the Play All mode. 

Stop – Stops playing wav file and ends the Play All mode if active. 

Play Previous File – Plays previous file in the list. 

Play Next File – Plays next file in the list 

Last File Played – Displays the last file played. Double clicking the file will locate the file in the Windows 

Explorer window. 

Time Elapsed / Duration – diplays the time elapsed and total time duration of the file. 

 

  

Notes: 

• Click to Play allows you to play the voice file associated with the metadata. 

• You can sort a particular column by clicking the column header. 

• Green rows represent RX. Red indicates TX. 

• Date and Time will always be in the time zone the radio was set to. 

• Volume can be displayed as an absolute number or percentage depending on how this is set up 

in the settings programming screen. 

• Call Type, Call To and Call From will be blank unless the transmission was NXDN digital. 
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• My Latitude, My Longitude and My Altitude may be blank even if the radio has GPS on. If the 

GPS cannot obtain a position when the call was made or received (in-doors, for example) it will 

not show a position in this table. Once GPS has locked on My Altitude may take a little bit longer 

to obtain a fix and so there may be a delay in the display of that value. 

• RX Latitude, RX Longitude and RX Altitude may be blank if the radio you’re receiving is not 

sending a GPS position. Keep in mind, even if the radio you’re receiving is set to send its GPS 

position, one will not be received if it does not currently have a fix. RX Altitude may take a little 

longer to display once a fix is achieved on the radio being received. 

• SQL / SQL Tight / Scan / Alert / marked fields may only be populated when viewing results from 

a F3400 Railroad version 2.8G or better. 

• On the F3400/F5400Series radio (IDAS or RR version) & F7010_F7510 series radios, for RX 

Altitude to display, the radio you are receiving must be using the GGA NEMA sentence selection: 

 

For RDT Pro, the F7000 series product does not record the following: 

▪ Zone/Channel information 

▪ Volume Level 

▪ RX GPS Position from Secondary Unit 

▪ SQL / SQL Tight / Scan / Alert / Marked  

For RDT Pro, the R30/R8600 series product does not record the following: 

▪ Zone/Channel or site information 

▪ Volume 

▪ TX Power (as it is an RX only unit) 

▪ Call Type 

▪ ESN Number 

▪ SQL / SQL Tight / Scan / Alert / Marked  

Voice to .kml File 
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When voice logs are first converted, Google Earth will open up and display map the information you’ve 

selected.  

It also generates a .kml file that you can work with should you close that window. To access, use your 

computer’s file system to navigate to the folder that has the target ESN value of the radio you 

converted. There you will see a .kml file with the ESN number of the converted radio which you can then 

click to open file in Google Earth. 

Whether you use Google Earth that was automatically opened when you converted the file, or open it 

sometime later, you will see a map that looks roughly like this: 

 

Each paddle style place mark indicates the position of the radio recording the data (not the radio being 

received).  

Color indicates RSSI value, as shown below. 

• Green: -100dB or better 

• Blue: -101dB to 110dB 

• Yellow: -111dB to -118dB 

• Red: less than -118dB 

• Purple: TX 

If there is a “dot” in the paddle place mark, it means that the transmission is longer than 512ms (useful 

for potentially differentiating between a static burst and an actual transmission) 

Clicking on a place mark will show more information regarding a particular transmission or reception. 
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Example from F3400 series radio 

 

Example from F7000 Series radio (RDT Pro Only) 

 

Example from F30 Radio (RDT Pro Only) 

You can also play back the audio from a selected place mark by scrolling down on the pop-up window 

and selecting “Play Audio File” 
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Make sure you have the Google Earth settings as recommended in Disclaimers 

This product relies on data from the Icom radio and is no more accurate than the data derived from that 

device or the Google Earth tool used to present much of the data. This product is meant as an aid for 

troubleshooting problems with radio communications as well as incident analysis. It is not meant to be a 

navigational aid of any kind and events depicted should be verified independently depending on the 

severity of the issue. 

Prerequisites for the audio files to play back properly. 

When using NXDN, you may be receiving radios that are sending their GPS positions (you will see “RX 

Latitude” and “RX Longitude” values in the table in this case). If so, the position of the received radio will 

be displayed using the “pushpin” icon as below. Note that the color of pushpin indicates the RSSI value 

that the recording radio received that signal at (and will have a matching paddle place mark in regards to 

time received). 

 

Please note you can use the time slider tool if you’re looking for a recording during a specific period of 

time. 
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Convert GPS / Power Logs –  

Please see Disclaimers 

This product relies on data from the Icom radio and is no more accurate than the data derived from that 

device or the Google Earth tool used to present much of the data. This product is meant as an aid for 

troubleshooting problems with radio communications as well as incident analysis. It is not meant to be a 

navigational aid of any kind and events depicted should be verified independently depending on the 

severity of the issue. 

Prerequisites for information on how to set up GPS log recording and interval. 

Click Convert GPS Logs (if F3400/F5400 Series, F7000/F7500 Series or R30) or Convert GPS / Power Logs 

(if F3400/F5400 RR Series) will allow you to select the GPS/Power logs of your choice for map 

conversion. In addition, it will allow you to view power related information in both a table format and on 

Google Earth. 

Depending on settings, different things will occur when this button is activated: 

Auto Detect in General Settings 

If checked: 

• Icom radio is connected via USB and radio is in “Card Reader Mode” 

You will be taken to the top level directory for GPS logs on the radio’s SD card. Pick the folder 

with the date you are interested in and then one or more files you wish to convert 

• Icom radio is not connected via USB or not in “Card Reader Mode” You will get the following 

message. 

 

• Pressing “OK” will bring up a file selection screen to allow you to pick GPS logs from alternate 

locations 

If unchecked: 

• Regardless whether a radio is connected or not you will get a file selection screen to allow you 

to pick GPS logs from alternate locations 

Use Preset .kml Location for each Conversion in the GPS Log Settings 
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If checked: 

• The GPS log will be automatically converted and placed in the location as listed in the “.kml File 

Location” setting. 

• You’ll be returned to the main program screen. 

 If unchecked: 

• You will be presented with a file selection screen so that you can determine what directory you 

want your .kml file to be stored in.  

• Once OK is clicked the GPS file is converted. 

• You’ll be returned to the main program screen. 

Once the file chooser is displayed, pick the file you’d like to convert. Note that more than one log file 

can be selected using standard ctrl or shift Windows conventions when picking a file. The files will all be 

combined into one .kml file. 

After the files are selected, a Google Earth will open and look something roughly like this: 

 

And if Power Log information is available (if activated and using RR Firmware 2.6G or higher) then a 

table similar to this will display: 
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If Google Earth has been closed and you wish to reopen the log you just converted, navigate on your 

computer’s file system to the folder you selected for the converted GPS log to be stored. Double click on 

the newly created .kml file and Google Earth will open. 

Each white circle with a black dot in the middle represents a position. The green paddle place mark 

represents the start of the track and the red paddle place mark represents the end. 

Click on any place mark to get position and speed information for that point. Also, if power information 

is available at that position, it will be displayed also. 

  

Please note you can use the time slider tool if you’re looking for log information during a specific period 

of time. 
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Create Channel Announcement – F3400/F5400 and F7000/F7500 Series Radios only  

Clicking Create Channel Announcement allows you to quickly customize channel announcements from 

recordings made from the radio itself. 

 

To use, first record the announcements that you would like into the radio itself. Make sure that the 

radio is unplugged from any USB connection and create your voice files by hitting the PTT and speaking 

your channel announcements (do this on a time when your system is little used or place a dummy load 

on the antenna as the announcements you are recording are also going out as standard transmissions). 

For best results, speak your announcements with as little pause as possible from the start of PTT and 

when you start speaking. Also, make sure you quickly release the PTT at the end of your voice 

announcements. Finally, avoid long announcements as the users may tire of listening to them after a 

period of time. 

Once you are satisfied with your announcements, connect the radio you used to record the 

announcements to the PC running RDT and place in “Card Reader” mode. 

Browse:  Allows you to navigate to the specific folder and file you’d like to have converted to a voice 

announcement 

Play: Allows you to play back a selected file to ensure it is correct for the zone channel ID you’re 

applying 

Zone field: Put the zone number you’d like for the channel announcement you are creating 

Channel field: Put the channel number you’d like for the channel announcement you are creating 

Create: Creates channel announcement in the appropriate place and format on the Icom radio 

Once you have created a channel announcement, you can proceed to the next file by going back to 

Browse. When finished, disconnect the Icom radio from the PC and power cycle the radio. The radio will 

now use the channel announcements you just created and assigned. 
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USB Mode Select - F3400/F5400 Series and F3400/F5400 RR Series Radios Only 

Some Icom F3400 series products are shipped with the SD card flap sealed shut. In addition, the USB 

card on the F5400 series is not easily user accessible. 

To access SD card data, you can use the USB port on the Icom radio to connect to your computer and 

then put the radio in “Card Reader Mode”. 

There may be circumstances, however, where you do not want typical end users access to the SD Card 

through the USB port. To prevent this, you would remove the ability to activate “USB Mode Select” from 

the menu or any programmable buttons. 

If you do this, however, you now have no way to put the radio into “Card Reader” mode to move log 

data off the SD card. 

RDT’s USB Mode Select provides a way of switching to radio into card reader mode, even if USB Mode 

select has been removed from the radio’s menu or easily accessible buttons.  

There are two different methods of USB Mode Select: Mode 1 and Mode 2, which can be selected in the 

settings menu. 
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The advantage of Mode 1 is that it is simple to put the radio into “Card Reader Mode”, but you must 

power cycle the radio to return it to “Data Transfer Mode”. This mode is particularly useful when the 

computer is local to the radio and cycling power to the radio is practical. 

The advantage of Mode 2 is that you can toggle the radio remotely between Card Reader Mode and 

Data Transfer Mode but two cables are required for it to work correctly and it is more complex to set up. 

This mode is particularly useful if not using RR Firmware 2.6G or later or you are reading a radio 

remotely and do not have a practical way to power cycle the radio. 

Mode 1 

Mode 1 is only supported by RR Firmware 2.6G or later. 

To use Mode 1, simply connect a radio that is in “Data Transfer Mode” (default) to the computer with 

RDT using a USB cable. 

Pressing the “USB Mode Select” button will put the radio into “Card Reader Mode”. Once in that mode, 

you can proceed to convert Voice or GPS logs. 

When finished transferring logs, power cycle the radio and it will return to “Card Reader Mode”. 

  

A single USB cable between your computer and F3400 are all that’s required for Mode 1 operation 

Mode 2 

To set up the Mode 2 method of toggling USB Mode Select, certain parameters activated need to be 

activated in the radio.  Once done, you can toggle USB Mode Select via a second “control” cable. The 

second cable would be an Icom’s OPC-1862 cable for the F3400 series and a USB to 25 pin serial cable 

for the F5400 series. 

To have this work correctly, you first must set the following parameters on the Icom radio. 

On the following Key menu, set  Ext. Emer to USB Mode Select. Note, you cannot actually use the Ext. 

Emer input for anything else while this setting is set. 
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Next set the Mode field under Common > External I/O > Option > Multi-Connector/D-Sub 25pin to PC 

CMD V2. 

 

That’s all you need to do on the radio. Note that in the portable radio, if you attempt to program 

through the Multi-Connector (not USB port) that you must press “P1” first to bypass temporarily the PC 

CMD V2 setting. 
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Make sure that your com port is properly set in the settings menu. You will now be able to toggle modes 

as needed with the USB Mode Select button. 

There is no way at this time to determine the state of this button other than looking at the radio as you 

press the USB Mode Select button. But if it is in card reader mode and an SD card exists in the Icom 

radio, the SD card should mount on your desktop. 

Pressing the button again should cause the SD card to disappear from Window’s file explorer. This 

should be another indication to you that the card is back in “Data Transfer” mode. Please make sure you 

set the radio to “Data Transfer Mode” if you wish to program the radio via the USB port. 

*Please note that it is very important that you leave the radio in “Data Transfer” mode while 

recording audio files. If you leave it in “Card Reader” mode AND have a USB cable connect to a 

computer, the radio will not be able to store log files. 

 
Using an OPC-1862 as a “control cable” to toggle USB Mode Select for F3400 series 

 

Using a USB to DB25 adapter as a “control cable” to toggle USB Mode Select for F5400 series. 

Note: the USB to DB25 connection will typically consist of a USB to 9 pin converter and then a 9 pin to 25 

pin adapter. Icom America has successfully used a US Converters Model XS880 converter and a generic 

null-modem 9 to 25 pin adapter cable. 
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Remote Access using USB Mode Select 

To remotely access an Icom radio for the purposes converting voice and GPS logs, the following method 

has been shown to work in limited tested. Be aware that Icom America does not offer support for this 

technique and that this setup is being provided for informational purposes only. 

For this method to work, you will need to obtain a Silex DS-510 USB device server. Follow the direction 

that comes with the device to configure it to work on your network and install the SX Virtual Link 

software on the same computer that is running RDT. 

You will also need to configure your radios as described in the first part of this section. 

You will connect your Icom radio to the Silex USB Device server as in the graphics below. 

 

 

Connecting a Silex USB Device Server to a F5400D 

 

 

Connecting a Silex USB device server to a F3400 
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Following is an example of what the SX Virtual Link software will look like when the Silex USB device 

server is successfully hooked to a powered-on F3400 using one USB and one OPC-1862 cable 

 

SX Virtual Link Software with Icom radio connected. Note that the “Icom Inc. Icom Radio” port is 

currently connected as a “hard drive” (hence the icon) using the USB cable. The “Prolific Technology” port 

is the OPC-1862 control cable (note the icon associated with it).  

Note: For speedy reconnection, on each port, right click and select Automatically connect the device 

when it is available as shown in the following screen. 
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Once successfully connected, you can use the USB Mode Select button just as if the radio is local. 

Note:  

This application is for reading the files on the SD Card. Using this method to try and read the radios using 

the cloning software has not been successful. 

If you wish to update a remote radio, the recommended way is to transfer the .icf file or firmware to the 

SD card. Then locally update the radio using the menu commands built into the radio. 



 

40 

RDT Instructions | 

©2019 Icom America Inc. The Icom logo is a registered trademark of Icom Inc.  

LTE Connect – LTE Series model 

Pressing the LTE Connect field will immediately open the LTE Connect Viewer window and will open the 

IP Connection per the settings in the File > Settings > LTE Settings Tab > Connection screen, if not 

currently connected.  

 

Current connection status can be viewed in the status label located at the bottom of the window. 

When populated the LTE Connect window will contain real-time information related to your LTE units. 

When an LTE Unit is selected via the “Show on Map” the information for that unit will be recorded to 

the rdtLive.kml file. See Setting up Google Earth for RDT Live updates 

 for setting up Google Earth to link this file for automatic updates for viewing RDT Live real time data. 

LTE Connect viewer color representation: 

• Gray – units are not currently reporting a valid GPS signal 

• Yellow – data displayed is considered “old” data and is greater than 5 minutes old. 

• White – units are actively updating their GPS location and status  

• Red – unit is in Emergency Status 

Show On Map:  Selects LTE units to be viewed/tracked with the GPS kml file 

Connect/Disconnect:  Forces a connection or disconnect from the currently connected VE-PG4 or IP-

501M 

Historical Points ON/OFF: If set to ON it adds historical data (“breadcrumbs”) to selected/tracked LTE 

Units. OFF – Remove historical data and only provide current GPS information to selected/tracked LTE 

Units. 

GeoLocate All Rows: Forces select all LTE units to be viewed/tracked with the GPS kml file 

Display Units – Valid GPS/All Units: Select whether to see all units or only view units with a valid GPS 

signal being reported. 
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Data as viewed on Google Earth Pro 

Historical Points OFF – note the single entry (pushpin) for Unit ID 5 – Test 2.  
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Historical Points ON - view/track the latest 250 location points reported by the unit. 

 

• Earliest location point (starting point) is denoted with a diamond in a balloon. 

• Most recent location data is denoted as a push pin. 

When multiple units are being tracked with Historical  Points ON , multiple colors of pushpins/balloons 

will be used with one color associated with the track of one unit. 

Clicking on any location point within Google Earth will give more data related to that point. 
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SAT Series model 

Pressing the SAT button will immediately open the SAT Log Viewer window and will open the IP or Serial 

Connection per the settings in the File > Settings > SAT Settings Tab > Connection screen, if not 

currently connected. 

The base radio that RDT is connecting to must have the PC Command interface match the interface to 

be used by RDT. On the SAT-100, go to Functions > PC Command and select the interface that will be 

used by RDT. 

 

 

Current connection status can be viewed in the status label located at the bottom of the window. 

When populated the SAT Log view window will contain real-time information related to your SAT-100 

units as they transmit. When a SAT Unit is selected via the “Show on Map” the information for that unit 

will be recorded to the “C:\ProgramData\Icom America\RadioDiscoveryTool\KmlInfo\SAT\rdtLive.kml“ 

file. See Setting up Google Earth for RDT Live updates 

 for setting up Google Earth to link this file for automatic updates for viewing RDT Live real time data. 

SAT Log viewer color representation: 

• Gray – units are not currently reporting a valid GPS location 

• White – units are reporting a valid GPS location 

• Red – unit has sent a call to the priority talk group 
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Show On Map:  Selects SAT units to be viewed/tracked with the GPS kml file 

Connect/Disconnect:  Forces a connection or disconnect from the currently connected SAT-100M/H 

Historical Points ON/OFF: If set to ON it adds historical data (“breadcrumbs”) to selected/tracked SAT 

Units. OFF – Remove historical data and only provide current GPS information to selected/tracked SAT 

Units. 

GeoLocate All Rows: Forces select all SAT units to be viewed/tracked with the GPS kml file 

Display Units – Valid GPS/All Units: Select whether to see all units or only view units with a valid GPS 

signal being reported. 
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Data as viewed on Google Earth Pro 

Historical Points OFF – note the single entry (pushpin) for IMEI 300425060999990 – Test 1. 
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Historical Points ON - view/track the points reported by the unit over time. 

 

• Earliest location point (starting point) is denoted with a diamond in a balloon. 

• Most recent location data is denoted as a push pin. 

When multiple units are being tracked with Historical  Points ON , multiple colors of pushpins/balloons 

will be used with one color associated with the track of one unit. 

Clicking on any location point within Google Earth will give more data related to that point. 
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Message View 

Clicking anywhere in the message column of the SAT Log window will open the Message View window. 

 
 

Here you can see all the messages that have been received by RDT. Messages from all radios are shown 

by default but unchecking the “Show Message” box in the Radio Section will hide messages from that 

radio in the Messages section. 

Send Message 

To send a message from RDT to other radios, press the “Send Message” button in the SAT Log window 

to open the Send Message window. 
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In this dialog, you can choose the destination Talk Group and type a message up to 100 characters. After 

pressing Send you will get a notification that the message was sent successfully. 

 

 

 

Setting up Google Earth for RDT Live updates 

RDT Live generates the file rdtLive.kml with real time mapping updates for LTE or SAT units selected for 

viewing/tracking. Linking this file to GE allows the GE Map to refresh the current map view to represent 

the most recent RDT Live data available. 

In Google Earth Pro, select “My Places”. Choose Add->Network Link. 

 



 

49 

RDT Instructions | 

©2019 Icom America Inc. The Icom logo is a registered trademark of Icom Inc.  

Network Link 

 

Name the Link and browse to the location of rdtLive.kml. Typically the LTE file can be found in 

“C:/ProgramData/Icom America/RadioDiscoveryTool/KmlInfo/LTE Connect/rdtLive.kml” and the SAT file 

can be found in “C:/ProgramData/Icom America/RadioDiscoveryTool/KmlInfo/SAT/rdtLive.kml” 

Refresh Time 

Click the Refresh tab for the Link and set Time-Based Refresh to Periodically and set the update time 

appropriately. A typical setting would be 30 seconds or faster.  

Select Fly to View on Refresh as appropriate to force the map to fly to all units to be displayed on the 

map. Note you may wish to unselect this to if you are attempting to zoom in to see a particular unit. 
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Click OK to save these settings. You will see the new Network Link displayed in Google Earth. 

 

 


